Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000450ODTBX - Matlab Codepublic2013-04-26 20:582014-05-28 20:36
Reporterravidavi 
Assigned Toravidavi 
PrioritylowSeveritytweakReproducibilityN/A
StatusfeedbackResolutionreopened 
PlatformOSOS Version
Summary0000450: integev has redundant arguments related to event handling
DescriptionThe integev() function accepts both an odtbxOptions structure (argument 'options'), and a separate event handler function (argument 'evtfun'). It simply replaces any event function in options with evtfun.

This is redundant behavior, and possibly produces unintended results if the user unknowingly specifies different event functions within odtbxOptions and evtfun.
TagsNo tags attached.
Increment0
Release6.0
Attached Files

- Relationships
related to 0000402closedcarpente integ should handle events 

-  Notes
(0003345)
ravidavi (administrator)
2013-04-26 21:12
edited on: 2013-04-26 22:55

Since the 'evtfun' argument is redundant, it will be deprecated in a future ODTBX release. A warning indicating this has been added to integev(), in public repo commit 58377d7.

This should have no effect on current ODTBX use, since integev() is never called directly. It's only called from integ(), and never with the 'evtfun' argument.

(0003346)
ravidavi (administrator)
2013-04-26 22:56

Suspended, pending re-open when the 'evtfun' argument is completely removed from ODTBX.
(0003403)
ravidavi (administrator)
2013-11-25 22:09

The ODTBX R2013b release notes announce the impending deprecation of the 'evtfun' argument. It should be removed by R2014a.
(0003406)
ravidavi (administrator)
2013-12-06 23:23

Approved for removal by CCB.
(0003410)
ravidavi (administrator)
2014-05-28 20:36

Since this has been approved, the deprecated code/function args should be removed.

- Issue History
Date Modified Username Field Change
2013-04-26 20:58 ravidavi New Issue
2013-04-26 20:58 ravidavi Status new => assigned
2013-04-26 20:58 ravidavi Assigned To => ravidavi
2013-04-26 21:11 ravidavi Relationship added related to 0000402
2013-04-26 21:12 ravidavi Note Added: 0003345
2013-04-26 21:15 ravidavi Note Edited: 0003345 View Revisions
2013-04-26 22:55 ravidavi Note Edited: 0003345 View Revisions
2013-04-26 22:56 ravidavi Note Added: 0003346
2013-04-26 22:56 ravidavi Status assigned => resolved
2013-04-26 22:56 ravidavi Resolution open => suspended
2013-11-25 22:09 ravidavi Note Added: 0003403
2013-12-06 23:23 ravidavi Note Added: 0003406
2014-05-28 20:36 ravidavi Note Added: 0003410
2014-05-28 20:36 ravidavi Status resolved => feedback
2014-05-28 20:36 ravidavi Resolution suspended => reopened


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker