Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000462ODTBX - Matlab Codepublic2014-06-27 19:322014-11-25 19:00
Reporterravidavi 
Assigned Toravidavi 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Summary0000462: ODTBXOptions changes causing regression tests to fail
DescriptionSeveral regression tests are throwing errors as of R2013b, within the setOdtbxOptions() function. This function calls validateOdtbxOptions(), which makes sure that the input options structure is valid by comparing it to a known template options structure. In R2013b, new fields were added to the options structure, so any old structure loaded from a file (eg. loaded by a regression test) will not pass this test.

In addition, it is now required that the setOdtbxOptions() function be called to set options, instead of directly setting options.optname = value. This allows ODTBX to check that the variable being set is actually a part of the options structure.
Steps To ReproduceRun any of the following regression tests: gpsenh_vs_gpsmeas, estsrif, gpsmeas_testdriver, estseq. In addition, testMeasPartials throws an error caused by improper setting of the odtbx options structure.
TagsNo tags attached.
Increment0
Release6.5
Attached Files

- Relationships

-  Notes
(0003414)
ravidavi (administrator)
2014-11-25 04:52

Fixed in commits [4171af2] - [9e817f4]. set/getOdtbxFunctions now validate the options structure, and there are strict (enforced) rules on how to use them. All functions/examples/tests using the options structure have been updated and no longer throw errors.
(0003415)
ravidavi (administrator)
2014-11-25 04:53

Resolved pending CCB approval.
(0003419)
ravidavi (administrator)
2014-11-25 19:00

Closed per CCB approval.

- Issue History
Date Modified Username Field Change
2014-06-27 19:32 ravidavi New Issue
2014-06-27 19:32 ravidavi Status new => assigned
2014-06-27 19:32 ravidavi Assigned To => ravidavi
2014-11-25 04:52 ravidavi Note Added: 0003414
2014-11-25 04:53 ravidavi Note Added: 0003415
2014-11-25 04:53 ravidavi Status assigned => resolved
2014-11-25 04:53 ravidavi Resolution open => fixed
2014-11-25 19:00 ravidavi Note Added: 0003419
2014-11-25 19:00 ravidavi Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker